menu
Public Events Calendar
Visit
MyWalsh
Your browser does not support JavaScript!
today
Start date:
upcoming
day
week
month
Your browser does not support JavaScript!
Search for events:
apply filter
Show Virtual Events
Event Category
Athletic Competitions
Campus Community Programs
Colloquia
Conferences, Meetings, Seminars
Festival
Panel Discussions
Performances
Public Lectures
Service
Student Programs
Training
Workshop
OPTIONS:
Submit an Event
Friday, October 16, 2026
Export/Subscribe
Load more events
Export / Subscribe
Current Filters:
Event feed or embeddable widget?
Feed
Widget (code to copy and paste onto a website)
Data format?
RSS
JSON
XML
iCal - iCalendar (
RFC5545
, .ics)
jCal - iCalendar JSON (
RFC7265
, .jcs)
xCal - iCalendar XML (
RFC6321
, .xcs)
CSV
HTML list (copy & paste into Word, etc.)
Include download link?
True
False
Show details or summary?
Details
Summary
Event count
Total number of events returned:
Time frame
Default: pull events from "today" forward
Limit to
days from "today"
Date Range:
Start Date:
End Date:
Note: Event count takes precedence over date range!
Widget Options
Limit the number of events listed?
True
False
(default: false)
Limit to:
events
Show a title above event list?
True
False
(default: true)
Title:
(default: "Upcoming Events")
Highlight event dates or event titles?
By title
By date
(default 'by title')
Show description in listing?
True
False
(default: false)
Display end date in listing?
True
False
(default: true)
Display time in listing?
True
False
(default: true)
Display location in listing?
True
False
(default: false)
Your URL:
URL
Widget Code: